© Josep Ros. Con la tecnología de Blogger.

Consulta Técnica: Copia de VM con BESR y uso de VMware Server 2.0

Mi colega Eduardo Martínez, de Murcia, me formula la siguiente consulta:

Buenas tardes Josep, que tal todo? Desde Murcia ya pasando mucho calor! Como todo el mundo felicitarte por tu blog, me sirve mucho para consultas sobre virtaulización.

Un par de preguntas rápidas:

1) Siempre te leo decir que para copiar de seguridad de maquinas virtuales en caliente, hablo de VMware Sever, utilicemos Symantex Exec System Recovery, pero como debo utilizarlo?, instalándolo en la maquina física y copiando la carpeta de la maquina virtual? o instalándolo en la virtual y haciendo una imagen entera de la maquina?

Podías darme un explicación más detallada de cómo se debe hacer?

2) Estoy probando VMware Server 2.0 beta 2 por el tema de que acepta hasta 8 GB y tengo varias dudas:

a. Una es el tema de los certificados y el errores que me da siempre al entrar en la web.
b. Al arrancar varias maquinas virtuales me da este error que no se cómo solucionarlo.
c. Hay forma de usar una consola tipo a la VMware Server 1, y no este acceso web?
d. Sabes tú algo de cuándo saldrá la versión definitiva?

Adjunto imagen del error al arrancar.



Espero no haberte bombardeado demasiado a preguntas. Supongo que para ti estas preguntas son fáciles, pero a mí me están llevando loco, seguro que podrán ayudar a más gente en mi situación.

Gracias por todo.

Eduardo Martínez

Buenas Eduardo, por aquí también hace una calor bastante heavy. Suerte de la playita que está aquí cerca y nos deja ir cierta corriente fresquita. Aún recuerdo los veranos que pasé de peque en la bega baja del Segura (El Raal) y me siento importante por haber superado esos golpes de calor. Realmente lo de Murcia es brutal...

Veamos, te contesto a las cuestiones que me planteas:

1. Copia de VM con BESR. Muy fácil, ya lo has dicho en la misma pregunta. La solución es instalarlo en la máquina física y hacer en caliente la copia de las VM. Ten precaución cuando empieces porque VMware dice que una VM debe estar pausada o apagada cuando se copia para poderla restaurar con 100% de seguridad. El BESR tiene una posibilidad de poner scripts en el pre y en el post. Ahí debes utilizar la utilidad vmware-cmd para hacer un suspend y un start de las VM que quieras copiar.

2. Sobre VMware Server 2.0 comentarte que no sé cuándo sale la versión definitiva, yo pienso que puede ser después del verano, pero ni idea. Esta herramienta cambia mucho respecto a VMware Server 1. El cambio más significativo es el uso de la Consola que desaparece y pasa a ser sustituida por la misma herramienta con la que se gestiona un entorno ESX, esto es, el VMware Infrastructure Client (VI Client). Búscalo en el directorio donde has instalado el VMware Server y lo instalas, es una aplicación que te pedirá nombre de servidor, usuario y password, entonces ya lo podrás gesitonar. Respecto al tema de los certificados a mí me sucede con IE, pero no con Firefox. Instala el certificado, es importante. Lo que no te sé ayudar es el error que me envías. Por lo que puedo leer (la imagen no se ve muy bien) dice que no se puede concluir el inicio de la VM. Pruébalo desde el VI Client y nos cuentas...

Ánimo con la virtualización y con la calor...

Josep

2 comentarios:

Manu dijo...

Hola! en la imagen no se lee muy bien, pero creo que se cual es el error (me paso a mi mismamente xDD). Me encontre este error al pasar 2 maquinas de la version 1.0.5 a 2.0 y se soluciona borrando el archivo *.lck
Suerte!

alFREE2-s dijo...

Hola Josep, mucho gusto, mis felicitaciones por ser wmware expert jejjeje mi nombre es Alfredo y tengo un problema con con mi maquina virtual hecha con VMWARE SERVER 2.0.2 yo tengo instalado windows server 2003 64bits y en mi maquina virtual tambien tenia el mismo S.O. me ha funcionado bien durante bastante tiempo sin ningun problema hasta ahora que no puedo entrar en mi maquina virtual, ejecuto mi MV me logeo y carga lo que es el Power ON pero queda en 95% pegado y no me tira ningun error solo se queda ahi pegado y no entra al S.O. por consecuencia he probado multiples formas de arregar, desintale el vmware y lo volvi a instalar respaldando mis maquinas virtuales en otro disco y al instalarla he creado una nueva maquina virtual con lo que al momento de correr la nueva MV tambien se queda pegada en 95% he vuelto mis maquinas virtuales que uso y tambien sucede el mismo problema, lo extraño es que no me tira ningun error......
me he fijado en el log y analizando algunos fallas que ahi se ven pero no he logrado mucho en eso ademas me he fijado que hay unas carpetas que cierran los archivos .vmdk y .vmen terminando con .lck ojala me puedas ayudar y
de antemano muchas gracias!!!!

Consulta Técnica

[Consulta Técnica][bleft]

Virtualización

[Virtualización][twocolumns]

Naturaleza

[Naturaleza][grids]