© Josep Ros. Con la tecnología de Blogger.

Quitar tarjeta de red oculta en el registro: Aparece un mensaje de error al intentar establecer una dirección IP en un adaptador de red

Imagino que os habréis encontrado como chiquicientas mil veces el problema de que se quita por el procedimiento mecagoendios una tarjeta de red de un sistema Windows y se instala otra a la que se quiere asignar la misma dirección IP. Ahí es cuando se nos pregunta aquello de:

La dirección IP 192.168.0.69 que ha especificado para este adaptador de red ya está asignada a otro adaptador pepito. pepito está oculto en la red y la carpeta Conexiones de acceso telefónico porque no está físicamente en el equipo o es un adaptador heredado que no funciona. Si la misma dirección está asignada a ambos adaptadores y ambos se vuelven activos, sólo uno de ellos usará esta dirección. Esto puede generar una configuración incorrecta del sistema. ¿Desea escribir una dirección IP diferente para este adaptador en la lista de direcciones IP en el cuadro de diálogo Avanzada?

Total que si dices que sí regresas al cuadro de diálogo para cambiar la IP y si decides que no realmente estás poniendo la IP que quieres poner.

Pero te queda aquél gusanillo de ¿andecosño estará el puto adaptador asqueroso ese que está oculto en el registro de los www?

Afortunadamente para todo hay solución en esta vida menos para la muerte (y para ser político). La gente de Microsoft lo tienen todo previsto y nos proponen dos soluciones de lo más majas, a escoger. Ambas están en este interesante artículo de la KB de Microsoft:

http://support.microsoft.com/kb/269155/es

La primera de las dos soluciones propuesta es la menos compleja. Se basa en hacer 6 pasos:

1. Abrir una línea de comandos ejecutando cmd.exe.
2. Escribir: set devmgr_show_nonpresent_devices=1 y presionar ENTRAR.
3. Abrir el administrador de dispositivos escribiendo en la línea de comandos: DEVMGMT.MSC y pulsar ENTRAR.
4. En el Administrador de dispositivos pulsar en el menú Ver y marcar Mostrar dispositivos ocultos.
5. Expandir el ítem Adaptadores de red.
6. Seleccionar los adaptadores que aparecen en color atenuado, clic con el botón secundario del ratón y Desintalar.

Espero que os sirva de ayuda

9 comentarios:

David dijo...

Ya decia yo, que se tenia que poder quitar.Mira que pasa veces esa alerta, y la de veces que pasamos de el.

Peter dijo...

Este truco sirve también para desinstalar el mogollón de dispositivos USB y de otro tipo que vamos insertando en el equipo y que nunca vamos a volver a utilizar, pero que quedan instalados degradando el rendimiento del sistema.

Anónimo dijo...

Tenía este problema y después de un buen rato de buscar en goggle encontré tu blog, justo lo que necesitaba saber, muchas gracias!

Anónimo dijo...

Neat! you saved my ass.

Anónimo dijo...

Ya desintale la tarjeta que aparecía como oculta, pero todavía no puedo conectarme a internet, ni siquiera el ícono de "el cable de red esta conectado" aparece, que puedo hacer, por favor ayuda...
el_barto_387@hotmail.com

Anónimo dijo...

Excelente aporte. Estoy renovando la flota de server y ya me encontre dos veces con este problema. La primera vez lastima no encontré esta nota. Pero de aquí en más me simplificara la existencia.

Josep Ros dijo...

@ David, pues si, es cierto que muchas veces simplemente contestamos o pulsamos en el interfaz sin pensar ni lo que está pasando, las prisas... :-) Un abrazo!

@ Peter. Es cierto! sirve, por ejemplo, para quitar el montón de dispositivos ocultos que quedan tras un proceso P2V, aunque con el converter 4 ya la cosa va más fina, pero siempre queda alguno por ahí... Un abrazo!

@ Anónimo1. De nada, me alegro que te fuese bien!.

@ Anónimo2. Zankyu :-)

@ Anónimo3. Pues ni flowers de lo que te pasa, como no me des más datos...

@ Anónimo4. Me alegro que te haya servido.

Saludos para todos!

Paco dijo...

Hola Josep, me alegro de encontrarte de vez en cuando cuando busco cosas por ahi, siempre son utiles, un abrazo.

Paco, Valencia.

Alfredo Riguetti dijo...

Hola, me sirve el blog pero hice eso que me indicas pero no me aparece ninguna en color tenue, y me sigue dando el error

muchas gracias por ayudar

Consulta Técnica

[Consulta Técnica][bleft]

Virtualización

[Virtualización][twocolumns]

Naturaleza

[Naturaleza][grids]